2

Closed

Installation problem

description

Hey there,
 
I have a problem with installing the add-in. On an up-to-date Windows 7 system (32bit) the following message pops up while installing:
 
Name:
From: file:///C:/Users/Johannes/Desktop/Writespace/Writespace.vsto
 
"The required version of the .NET Framework is not installed on this computer."
 
************** Exception Text **************
Microsoft.VisualStudio.Tools.Applications.Deployment.InstallAddInFailedException: "The required version of the .NET Framework is not installed on this computer."
bei Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()
bei Microsoft.VisualStudio.Tools.Office.Runtime.SolutionInstaller.<>c__DisplayClass7.<Install>b__0()
 
How can I make this work? Thanks in advance!
 
Johannes
Closed Feb 2, 2016 at 10:01 PM by JohanDanforth
new setup program now

comments

kaotic wrote Dec 6, 2009 at 10:37 AM

I'm having the same problem with both windows 7 and windows xp.

johneegeek wrote Jan 13, 2010 at 7:07 PM

I have the same problem. (Windows 7)

"The required version of the .NET Framework is not installed on this computer."

************** Exception Text **************
Microsoft.VisualStudio.Tools.Applications.Deployment.InstallAddInFailedException: "The required version of the .NET Framework is not installed on this computer."
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()
at Microsoft.VisualStudio.Tools.Office.Runtime.SolutionInstaller.<>c__DisplayClass7.<Install>b__0()

johneegeek wrote Jan 13, 2010 at 7:08 PM

I have the same problem. (Windows 7)

"The required version of the .NET Framework is not installed on this computer."

************** Exception Text **************
Microsoft.VisualStudio.Tools.Applications.Deployment.InstallAddInFailedException: "The required version of the .NET Framework is not installed on this computer."
at Microsoft.VisualStudio.Tools.Applications.Deployment.ClickOnceAddInDeploymentManager.InstallAddIn()
at Microsoft.VisualStudio.Tools.Office.Runtime.SolutionInstaller.<>c__DisplayClass7.<Install>b__0()

wrote Feb 7, 2010 at 9:43 AM

wrote Feb 7, 2010 at 9:43 AM

wrote Feb 7, 2010 at 9:47 AM

wrote Feb 7, 2010 at 9:47 AM

wrote Feb 7, 2010 at 9:49 AM

wrote Feb 7, 2010 at 11:13 AM

wrote Feb 7, 2010 at 11:49 AM

wrote Feb 7, 2010 at 12:16 PM

wrote Feb 7, 2010 at 12:18 PM

wrote Feb 7, 2010 at 12:18 PM

wrote Feb 7, 2010 at 12:21 PM

wrote Feb 7, 2010 at 12:22 PM

wrote Feb 7, 2010 at 12:23 PM

wrote Feb 7, 2010 at 12:23 PM

wrote Feb 7, 2010 at 12:27 PM

wrote Feb 7, 2010 at 12:28 PM

wrote Feb 7, 2010 at 12:28 PM

wrote Feb 7, 2010 at 12:29 PM

wrote Feb 7, 2010 at 12:29 PM

wrote Feb 7, 2010 at 12:29 PM

wrote Feb 7, 2010 at 12:29 PM

wrote Feb 10, 2010 at 1:05 PM

wrote Feb 10, 2010 at 1:09 PM

wrote Feb 10, 2010 at 1:11 PM

wrote Feb 10, 2010 at 1:15 PM

wrote Feb 25, 2010 at 9:15 PM

wrote Feb 25, 2010 at 9:16 PM

wrote Mar 31, 2010 at 12:09 PM

wrote Mar 31, 2010 at 12:09 PM

JohanDanforth wrote May 7, 2010 at 3:37 PM

I've heard the same thing from another source as well, and it may be because of a known clickonce issue you can read about here -> http://blogs.msdn.com/vsto/archive/2009/05/07/issues-with-installing-vsto-projects-that-were-published-from-visual-studio-2008-on-windows-7-rc-saurabh-bhatia.aspx

I'm about to create new setup/msi programs and upload them.

wrote Sep 24, 2010 at 2:16 PM

wrote Sep 25, 2010 at 6:32 PM

wrote Feb 14, 2013 at 1:35 AM

wrote Feb 2, 2016 at 10:01 PM